Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 26, 2026 - 22:30 CAT
Scheduled
Ku bakoresha IremboGov,
Turabamenyesha ko hateganyijwe igikorwa cy’ivugurura rya sisitemu y’urubuga IremboGov kuwa 26 Kanama 2026, guhera saa 10:30 z’ijoro kugeza saa 04:30 za mugitondo.
Muri iki gihe, urubuga IremboGov kuri www.irembo.gov.rw rushobora kuba rutarimo gukora mu gihe cy’amasaha agera kuri 3.
Murakoze.
Dear IremboGov Users,
Please note that there is a planned system maintenance on the IremboGov platform tonight Wednesday, August 26, 2026, from 10:30 PM to 04:30 AM (CAT).
During this period, the IremboGov platform at www.irembo.gov.rw will be unavailable for approximately 3 hours.
We apologize for any inconvenience this may cause and appreciate your understanding.
Thank you.
Posted Aug 26, 2026 - 19:12 CAT
This scheduled maintenance affected: IremboGov Website (RNP, RSSB, RLMUA, MINALOC, NIDA, NPPA, DGIE, RRA, RURA, REB, MUSEUMS (INMR), NOTARY, MINIJUST (Gazette), NESA, DGIE - Visa on arrival and overstay penalties, RIB).