Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 15, 2026 - 22:00 CAT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 15, 2026 - 19:34 CAT
Scheduled
Ku bakoresha IremboGov,
Turabamenyesha ko hateganijwe igikorwa cy’ivugurura rya serivisi za polisi uyu munsi saa yine z’ijoro (22:00), kugeza saa sita z'ijoro (00:00).
Muri iki gihe, hashobora imbogamizi mu gusaba izi serivisi.
Murakoze.
Dear IremboGov users,
Please note that there is a planned system maintenance on police services available on IremboGov tonight, scheduled to start from 22:00 PM to 00:00 AM.
During this period, users might not be to apply for these services.
Thank you!
Posted May 15, 2026 - 19:34 CAT
This scheduled maintenance affected: IremboGov Website (RNP).