Turabamenyesha ko ikibazo tekinike twari dufite mu gusaba serivisi yo kwandikisha aderesi ya ePoBox. cyakemutse. Twongeye kubashimira ukwihangana kwanyu mu gihe twakemuraga ikibazo.
The technical issue that had caused an interruption with Register an ePoBox Address is now resolved. We thank you for your patience while we were resolving the issue.
Posted Jul 16, 2026 - 10:42 CAT
Investigating
Ku bakoresha IremboGov, Turabamenyesha ko hari imbogamizi mu gusaba serivisi yo Kwandikisha aderesi ya ePoBox unyuze ku rubuga IremboGov. Turi kubikurikirana kandi turabamenyesha nibikemuka.
Murakoze.
Dear IremboGov Users, Please be advised that there is a technical interruption affecting the Register an ePoBox Address service on the IremboGov platform. We are investigating the matter and will update you once it's resolved.
Thank you.
Posted Jul 14, 2026 - 08:54 CAT
This incident affected: Upgraded IremboGov website (E-POBOX).