Ku bakoresha IremboGov,Turabamenyesha ko imbogamizi mu kwishyura serivisi no kwakira kode yo kwishyuriraho ku rubuga IremboGov na RDB One Stop Centre zakemutse.
Mwakoze kwihangana
Dear IremboGov Users,This is to inform you that the technical interruption in generating bill ID and paying for services on the IremboGov and RDB One Stop Centre platforms has been resolved.
Thank you for your patience
Posted Jan 16, 2026 - 10:02 CAT
Investigating
Ku bakoresha IremboGov, Turabamenyesha ko hari imbogamizi mu kwishyura serivisi no kwakira kode yo kwishyuriraho ku rubuga IremboGov na RDB One Stop Centre. Tubiseguyeho ku mbogamizi byateje. Turabasaba kwihangana mu gihe turi gukemura iki kibazo. Turabamenyesha nigikemuka.
Murakoze.
Dear IremboGov Users, This is to inform you that there is a technical interruption in generating bill ID and paying for services on the IremboGov and RDB One Stop Centre platforms. We apologize for the inconvenience caused. Kindly bear with us, as we work to resolve the matter. We will update you once it's resolved.
Thank you.
Posted Jan 16, 2026 - 08:48 CAT
This incident affected: IremboGov Website (RNP, DGIE, DGIE - Visa on arrival and overstay penalties, NIDA, MINALOC, RLMUA, RSSB, RURA, REB, NPPA, MUSEUMS (INMR), NOTARY, MINIJUST (Gazette), MHC, NESA, RGB, HEC, RBC, RCHA, RIB, MINICOM) and Upgraded IremboGov Website (E-POBOX, RW Domain Registration).