Kwishyura ukoresheje MOMO Push ntabwo biri gukora. Payment through MOMO Push is currently not working.

Incident Report for IremboGov

Resolved

Turabamenyesha ko kwishyurira serivisi ukoresheje MoMo Push byakunze. Ubu mushobora gukoresha serivisi za IremboGov nk'uko bisanzwe. Murakoze

Payment through MoMo Push is now available. You may now use IremboGov services normally. Thank you
Posted Jul 08, 2025 - 18:01 CAT

Investigating

Ku bakoresha IremboGov,
Kwishyura ukoresheje MOMO Push ntabwo biri gukora. Mwakoresha indi miyoboro ari yo VISA,MOMO Pull (*182#),BK (BK App, BK Yacu, BK IB), na MasterCard. Tubiseguyeho ku mbogamizi byateza, tubizeza ko ikibazo kiri gukurikiranwa kugira ngo bikosorwe.

Dear IremboGov Users,
Payment through MOMO Push is currently not working. We are working on fixing the issue as soon as possible. In the meantime, you can pay using our alternative payment channels: VISA, MOMO Pull(*182#), BK (BK App, BK Yacu, BK IB), and Mastercard. We apologize for any inconvenience caused.
Posted Jul 08, 2025 - 17:35 CAT
This incident affected: Payments (MTN Mobile Money).