Ubutinde ku rubuga IremboGov, Temporary slowness on the IremboGov platform

Incident Report for IremboGov

Resolved

Ikibazo cyateraga ubutinde ku rubuga IremboGov cyakemutse. Ubu serivisi ziri kuboneka nk'uko bisanzwe.

Murakoze

The issue that had caused IremboGov's latency is now fully resolved. You can continue to request services as usual.

Thank you.
Posted Aug 10, 2026 - 12:34 CAT

Investigating

Ku bakoresha IremboGov,

Turabamenyesha ko bamwe mu bakoresha urubuga www.irembo.gov.rw bashobora guhura n'imbogamizi z'ubutinde kuri uru rubuga, bitewe n'ikibazo kuri sistemu y'umwe mu bafatanyabikorwa bacu.

Turi gukorana kugira ngo serivisi zongere kuboneka vuba.

Turabamenyesha serivisi ni zisubira gukora nk’uko bisanzwe.

Murakoze.


Dear IremboGov users,

We are currently experiencing a technical disruption that is causing slowness on the IremboGov platform (www.irembo.gov.rw. As a result, some users may not be able to open it or access services.

The disruption is due to an issue affecting one of our partners. Our technical team is actively working with the partner to resolve the issue as a matter of urgency.

We will notify you as soon as it's resolved.

Thank you
Posted Aug 10, 2026 - 11:08 CAT
This incident affected: IremboGov Website (RNP, RSSB, RLMUA, MINALOC, NIDA, NPPA, DGIE, RRA, RURA, REB, MUSEUMS (INMR), NOTARY, MINIJUST (Gazette), MHC, NESA, RGB, HEC, Applications Finder, Login, RBC, Sign up, RCHA, RIB, MINICOM, Government officers portal).