Imbogamizi mugusaba serivisi z'ubutaka. National land services are currently not available.
Incident Report for IremboGov
Resolved
Turabamenyesha ko serivisi zose z'ubutaka ziri gukora neza. Abasaba serivisi bashobora gusaba no kwishyurira serivisi nk'uko bisanzwe.
Tubiseguyeho ku mbogamizi byaba byateje.

Please be informed that all land services are currently available. Applicants can now apply for and pay for all the land services.
We apologize for the inconvenience caused.
Posted Nov 12, 2024 - 10:03 CAT
Identified
All land services are currently not available. We apologize for any inconvenience that may occur at the moment. While we are working on finding a quick resolution, we shall keep you informed of the progress.

Serivisi z'ubutaka ntiziboneka aka kanya. Mu gihe turimo gushaka igisubizo kuri iyi mbogamizi, tubasabye kwihangana tubizeza kubamenyesha aho tugeze tubikemura.
Posted Nov 12, 2024 - 08:42 CAT
This incident affected: IremboGov Website (RLMUA).