Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 31, 2025 - 23:00 CAT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 31, 2025 - 21:14 CAT
Scheduled
Ku bakoresha IremboGov, Turabamenyesha ko haza kubaho igikorwa cy’ivugurura ku mbuga za AOS, umufatanyabikorwa wacu, kuri uyu wa kane taliki 31 Nyakanga 2025, guhera saa tanu z’ijoro. Muri iki gihe, gusaba zimwe muri serivisi ku rubuga IremboGov ruvuguruye (new.irembo.gov.rw), IremboPlus na OSC ntibiza gukunda by'agateganyo.
Murakoze.
Dear IremboGov users, Please be advised that there will be a scheduled system maintenance activity with our partner, AOS, tonight, Thursday , 31st July 2025, from 11 PM. During this time, some services on the upgraded IremboGov (new.irembo.gov.rw) IremboPlus and OSC will be temporarily inaccessible.
We apologize for any inconvenience this may cause. Thank you