Ubutinde ku rubuga IremboGov, Temporary Slowness on the IremboGov Platform

Incident Report for IremboGov

Resolved

Ku bakoresha IremboGov,
Turabamenyesha ko imbogamizi zateraga ubutinde ku rubuga IremboGov zacyemutse.

Mwakoze kwihangana.

Dear IremboGov Users,
This is to inform that the technical difficulties that caused the platform's slowness have been resolved.
Posted Jan 15, 2026 - 16:36 CAT

Investigating

Ku bakoresha IremboGov,
Turabamenyesha ko bamwe mu bakoresha IremboGov bashobora guhura n'ikibazo cy'ubutinde kuri uru rubuga.
Tubiseguyeho mu gihe dukora ibishoboka byose ngo bikemuke. Turabamenyesha nibikemuka.

Murakoze.

Dear IremboGov users,
Some users may experience slowness on the IremboGov platform. Services are still accessible, and our team is working to resolve the matter.
We apologize for the inconvenience and will keep you updated on our progress.

Thank you.
Posted Jan 15, 2026 - 16:16 CAT
This incident affected: IremboGov Website (RNP, DGIE, DGIE - Visa on arrival and overstay penalties, NIDA, MINALOC, RLMUA, RSSB, RURA, REB, NPPA, MUSEUMS (INMR), NOTARY, MINIJUST (Gazette), MHC, NESA, RGB, HEC, Applications Finder, Login, RBC, Sign up, RCHA, MINICOM, Government officers portal).