Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 30, 2025 - 02:00 CAT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 29, 2025 - 20:28 CAT
Scheduled
Ku bakoresha IremboGov,
Turabamenyesha ko haza kubaho igikorwa cy’ivugurura ya sistemu z’umufatanyabikorwa wacu, MoMo Rwanda, taliki 30 Nzeri 2025, guhera saa munani z’ijoro (02:00) kugeza saa kumi n’imwe za mu gitondo (05:00).
Muri iki gihe, kwishyura serivisi zishyurwa ku rubuga IremboGov hakoreshejwe MoMo Push (*182# → Kwemeza kwishyura) na MoMo Pull (*182# → Kwishyura) ntibiza gukunda; serivisi zitishyurwa zo zirakomeza kuboneka nk'uko bisanzwe.
Mwakoresha indi miyoboro ariyo; Amakarita (Visa, Mastercard, American Express) Airtel Money I&M Bank Banki ya Kigali (BK App)
Tubiseguyeho ku mbogamizi bishobora gutera.
Murakoze. ------------- Dear IremboGov Users, Please note that our partner, MTN Mobile Money, will be conducting a scheduled system maintenance tonight, Tuesday, 30 September 2025, from 02:00 AM to 05:00 AM. Impact: Payments on IremboGov and IremboPay using MTN MoMo Push (* 182 * 7 # → CashOut Approval) and MTN MoMo Pull (*182 * 3 # → Pay Bill) will be temporarily unavailable. We advise you to use the following alternative payment channels: Cards (Visa, Mastercard, American Express) Airtel Money I&M Bank Bank of Kigali (BK App) We apologize for any inconvenience this may cause and appreciate your understanding. Thank you
Posted Sep 29, 2025 - 20:28 CAT
This scheduled maintenance affected: Payments (MTN Mobile Money).