Serivisi yo kuzana kode yo kwishyuriraho iri gukora neza. Ubu mushobora gusaba serivisi za IremboGov nkuko bisanzwe. Murakoze.
Generating bill ID services is now working. We thank you for your patience while we were working on the issue. Thank you
Posted Jul 14, 2025 - 11:34 CAT
Update
Serivisi zo kwishyura no kuzana kode zo kwishyuriraho ntiziri gukora neza. Tubiseguyeho ku mbogamizi byateje, tubizeza ko ikibazo kiri gukurikiranwa kugira ngo bikosorwe. Turabamenyesha mu gihe ikibazo cyakemutse. Murakoze!
Generating bill ID and payment services are currently not stable. We are working on fixing the issue as soon as possible. We apologize for the inconvenience caused. We will share updates once the issue has been resolved. Thank you!
Posted Jul 10, 2025 - 14:25 CAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2025 - 15:29 CAT
Update
We are continuing to work on a fix for this issue.
Posted Jul 07, 2025 - 09:22 CAT
Identified
Serivisi zo kwishyura no kuzana kode zo kwishyuriraho ntiziri gukora neza. Tubiseguyeho ku mbogamizi byateje, tubizeza ko ikibazo kiri gukurikiranwa kugira ngo bikosorwe. Turabamenyesha mu gihe ikibazo cyakemutse. Murakoze!
Generating bill ID and payment services are currently not stable. We are working on fixing the issue as soon as possible. We apologize for the inconvenience caused. We will share updates once the issue has been resolved. Thank you!
Posted Jul 06, 2025 - 16:52 CAT
This incident affected: IremboGov Website (RNP, DGIE, DGIE - Visa on arrival and overstay penalties, NIDA, MINALOC, RLMUA, RSSB, RURA, REB, NPPA, MUSEUMS (INMR), NOTARY, MINIJUST (Gazette), MHC, NESA, RGB, HEC, Applications Finder, Login, RBC, Sign up, RCHA, RIB, MINICOM).