Turabamenyesha ko ikibazo tekinike twari dufite mu gusaba serivisi z'ubutaka cyakemutse. Twongeye kubashimira ukwihangana kwanyu mu gihe twakemuraga ikibazo.
The technical issue that had caused an interruption with land services is now resolved. We thank you for your patience while we were resolving the issue.
Posted May 10, 2025 - 13:44 CAT
Investigating
Turabamenyesha ko hari imbogamizi mu gusaba serivisi z'ubutaka. Tubasabye kwihangana mu gihe ikipe tekinike iri gukurikirana iki kibazo. Turabamenyesha nibikemuka. Murakoze!
Land services are currently experiencing a technical interruption. Please bear with us while the technical team is resolving this issue. We will inform you of the progress. Thank you!
Posted May 10, 2025 - 13:20 CAT
This incident affected: IremboGov Website (RLMUA).