Urubuga rw'Irembo ntirurimo gukora neza - IremboGov platform is experiencing slowness

Incident Report for IremboGov

Resolved

Urubuga rw'Irembo ubu rurakora neza. Turakomeza gukurikiranira hafi uko serivisi zirimo gukora kugirango zirushweho kunozwa. Mwakoze kutwihanganira mugihe twarimo ducyemura iki kibazo

IremboGov Platform is now working well, the technical issue we faced has been resolved. We will continue to monitor closely their performance to ensure stability. Thank you for your patience while we were working on the issue.
Posted Aug 12, 2025 - 16:16 CAT

Identified

Serivisi z'Irembo ntizirimo gukora neza kubera ubutinde buri ku rubuga, tubiseguyeho ku mbogamizi byateje. Abatekinisiye bacu barimo gusuzuma ikibazo. Turi bubamenyeshe ikibazo gikemutse.

Services on IremboGov are currently not working well due to slowness on the platform, we apologize for the inconvenience faced. Our team is working to resolve this issue urgently. We will update you once this issue is resolved.
Posted Aug 12, 2025 - 16:03 CAT
This incident affected: IremboGov Website (RNP, DGIE, DGIE - Visa on arrival and overstay penalties, NIDA, MINALOC, RLMUA, RSSB, RURA, REB, NPPA, MUSEUMS (INMR), NOTARY, MINIJUST (Gazette), MHC, NESA, RGB, HEC, Login, RBC, Sign up, RCHA, RIB, MINICOM, Government officers portal).